add runtime dependencies for gemspec

parent 5ce23ad1
source 'https://rubygems.org'
gem 'simplecov'
# Specify your gem's dependencies in mark.gemspec
gemspec
gem 'json'
......
......@@ -4,7 +4,7 @@ $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'dspace/version'
Gem::Specification.new do |spec|
spec.date = '2015-11-23'
spec.date = '2015-12-04'
spec.name = "dspace_rest_client"
spec.version = Dspace::VERSION
spec.authors = ["Mauricio Giacomini Girardello", "Lucas Ernesto Kindinger", "Bruno N. Zanette", "Mateus Rambo Strey"]
......@@ -18,6 +18,12 @@ Gem::Specification.new do |spec|
spec.executables = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
spec.require_paths = ["lib"]
spec.add_runtime_dependency "json", '~> 1.8', '>= 1.8.3'
spec.add_runtime_dependency "resource_kit", "~> 0.1.4"
spec.add_runtime_dependency "faraday", "~> 0.9.2"
spec.add_runtime_dependency "net-http-persistent", '~> 2.9', '>= 2.9.4'
spec.add_runtime_dependency "activesupport", '~> 4.2', '>= 4.2.0'
spec.add_development_dependency "bundler", "~> 1.10"
spec.add_development_dependency "rake", "~> 10.0"
spec.add_development_dependency 'rspec', '~> 3.4', '>= 3.4.0'
......
module Dspace
VERSION = "2.0.0"
VERSION = "2.0.1"
end
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment