Commit c72b0793 authored by Lior Spach's avatar Lior Spach

le-pregao-712010: Refs #1280 Corrected syntax error (etc/init.d/pregao71)

Signed-off-by: Lior Spach's avatarLior Spach <ls12@inf.ufpr.br>
parent 9f95a688
......@@ -5,7 +5,7 @@ if dpkg -l le-pregao-712010 | grep -q ^ii; then
if test -f "/var/log/le-oldkernelversion"; then
# if we know old kernel version
old_version=$(cat "/var/log/le-oldkernelversion")
actual_version=$(uname -r)
actual_version="$(uname -r)"
if test ${old_version} != ${actual_version}; then
# if kernel was upgraded
/usr/lib/dkms/common.postinst lepregao712010 2.3.0.0-Alpha-v2
......@@ -20,11 +20,11 @@ if dpkg -l le-pregao-712010 | grep -q ^ii; then
# if modprobe fail, will not have problem, this mean that
# the driver is already on kernel (I hope)
#test -n "`cat /proc/modules | grep rt3562sta`" && rmmod rt3562sta
modprobe rt3562sta
modprobe rt3562sta &> /dev/null
fi
# Verify if the kernel is in hold state
if test $(dpkg --get-selections | grep linux-image-generic-pae | tr -s [:blank:] | cut -f2) != "hold"; then
if test "$(dpkg --get-selections | grep linux-image-generic-pae | tr -s [:blank:] | cut -f2)" != "hold"; then
echo "linux-image-generic-pae hold" | dpkg --set-selections
echo "linux-headers-generic-pae hold" | dpkg --set-selections
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment