README.md 614 Bytes
Newer Older
Vytor Calixto's avatar
Vytor Calixto committed
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
# LDE Admin API

# Dependencies

Previous versions of Node.js do not support ECMAScript6, it is recommended to use **at least** version 6.8.1.

1) Install [NVM (Node Version Manager)](https://github.com/creationix/nvm)

2) Install Node.js via NVM

> source ~/.bashrc

> nvm install v4.5.0

3) Enable Node.js

> nvm use v6.8.1

4) Install the global dependencies

> npm install --global gulp gulp-cli babel babel-cli babel-core babel-register mocha gulp-mocha gulp-eslint istanbul

5) Install project dependencies

> npm install

6) Copy `config.json.example` to `config.json`

> cp config.json.example config.json